3
\$\begingroup\$

Currently if I try to open https://electronics.stackexchange.com/questions/ask and ask a question in Firefox or Chrome the preview won't work. Here's a screenshot:

enter image description here

You see, there's no text in the preview area, no toolbar and there's a "Mathjax not defined" error message in the JavaScript console. Firefox console shows the same error message.

\$\endgroup\$
  • \$\begingroup\$ Looks like it is a wider problem meta.stackexchange.com/questions/133611/… \$\endgroup\$ – sharptooth May 25 '12 at 9:47
  • \$\begingroup\$ norepo on chrom with windows 7 for me. \$\endgroup\$ – Kortuk May 25 '12 at 10:42
  • \$\begingroup\$ @Kortuk: I guess it is specific to user location. Perhaps some network problem. Anyway not being able to load Mathjax should not break the toolbar and the preview. \$\endgroup\$ – sharptooth May 25 '12 at 10:48
  • \$\begingroup\$ @sharptooth - I can't reproduce it here. Are you behind a proxy or something like that? Good point, though, about needing a graceful degradation if MathJax won't load. \$\endgroup\$ – Kevin Vermeer May 25 '12 at 13:18
  • \$\begingroup\$ @Kevin Vermeer: I'm behind Microsoft ISA Server, but this has been here for ages and these problems with MathJax only started today. I guess it is something network-related - maybe the CDN can't serve requests from my network or something like that. \$\endgroup\$ – sharptooth May 25 '12 at 13:22
  • \$\begingroup\$ @sharptooth, I was not trying to imply you were not having the issue, just quickly adding information for anyone that might be debugging it. A while back imgur had issues that just caused Europe to not be able to load images. I hope it gets resolved. \$\endgroup\$ – Kortuk May 25 '12 at 15:19
  • \$\begingroup\$ @Kortuk: Yes, I realize that, I just provide the details I can think of. Still not having graceful degradation is a problem - any third-party service can become temporarily unavailable and it shouldn't have that much effect. \$\endgroup\$ – sharptooth May 28 '12 at 5:32
  • \$\begingroup\$ Any progress on this @sharptooth? \$\endgroup\$ – Kortuk May 30 '12 at 4:01
  • \$\begingroup\$ @Kortuk: I found it's specific to my computer. So I guess it's some environment problem. I created this feature request meta.stackexchange.com/q/133824/132564 to make the interface degrade only partially. \$\endgroup\$ – sharptooth May 30 '12 at 10:29
  • \$\begingroup\$ @sharptooth, Well I guess I will flag this status-repo for now then if it is specific. scratch that, status no-repo means it is either fixed for all users or determined no repo by dev team. I cannot flag it that unless your problem is resolved. \$\endgroup\$ – Kortuk May 30 '12 at 10:35

You must log in to answer this question.

Browse other questions tagged .