7
\$\begingroup\$

If an unregistered user's name is long enough, it will cause the network profile and mod links to wrap to a second, hidden line. You can access this line by drag-selecting the username down, but there is no scroll-bar.

For example, see the user account that I created for this purpose:

https://electronics.stackexchange.com/users/22132/long-usernames-cause-wordwraps

Below is an image that illustrates the differences between a long username, and a short username.

enter image description here

| |
\$\endgroup\$
  • 2
    \$\begingroup\$ I don't see what you mean. Everything seems fine here. Can you add a screenshot? \$\endgroup\$ – user17592 Apr 4 '13 at 19:49
  • \$\begingroup\$ What are 'mod links'? Network profile is on the same line when I see it. Perhaps it only wraps for the user when he is logged in, and not to other users? \$\endgroup\$ – Tim Apr 4 '13 at 20:03
  • 2
    \$\begingroup\$ @CamilStaps I believe it may only be a bug for moderators. Sorry you can't enjoy this one too ;) \$\endgroup\$ – W5VO Apr 4 '13 at 20:06
  • \$\begingroup\$ I don't see any wordwrap: can you share a screenshot? \$\endgroup\$ – Sklivvz Apr 4 '13 at 21:13
  • 1
    \$\begingroup\$ Looks fine to me too. However, anyone that creates a user name that absurdly long deserves to have it get truncated and look stupid. Don't do that (duh). \$\endgroup\$ – Olin Lathrop Apr 4 '13 at 21:20
  • \$\begingroup\$ @Sklivvz It's actually showing in your screenshot. See my annotated screenshot. \$\endgroup\$ – W5VO Apr 5 '13 at 2:28
  • 1
    \$\begingroup\$ @OlinLathrop there already is a maximum length of 30. I think it would be better to adapt the theme to that maximum. \$\endgroup\$ – user17592 Apr 5 '13 at 6:32
  • \$\begingroup\$ By the way, this isn't only a bug for moderators, you can see it yourself when giving your own profile a very long name. \$\endgroup\$ – user17592 Apr 5 '13 at 6:33
4
\$\begingroup\$

I've limited the display size of the user name in that page to 400px.

enter image description here

It will be rolled out in the next build.

| |
\$\endgroup\$
  • \$\begingroup\$ Hrm... now the line wrap appears to be happening much more frequently - on most EE.SE users now. Oddly enough, the meta.EE.SE accounts look mostly fine. \$\endgroup\$ – W5VO Apr 6 '13 at 5:43
  • \$\begingroup\$ Typo :-) Should be fixed shortly. \$\endgroup\$ – Sklivvz Apr 6 '13 at 12:42
  • \$\begingroup\$ @Sklivvz unintended feature, W5VO did not make a clear request, but if you have to you will change it again. :) \$\endgroup\$ – Kortuk Apr 7 '13 at 6:20
  • 1
    \$\begingroup\$ This bug has reoccured \$\endgroup\$ – W5VO Apr 29 '13 at 16:34
  • \$\begingroup\$ Still a bug, please come fix me. :) \$\endgroup\$ – Kortuk Jun 18 '13 at 20:02
  • \$\begingroup\$ Now the bug has gone global! \$\endgroup\$ – Manishearth Nov 6 '13 at 6:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .