4
\$\begingroup\$

Some images just fail to upload with mentioned error message. For example: What is wrong with this image that it is refused?

http://media.digikey.com/Photos/FCI%20Photos/10118192-0001LF.JPG

enter image description here

This happens every once in a while with an image.

My solution: Just copy/paste it in the GIMP, save it and it uploads fine.


EDIT1: Confirmed that @PeterJ's solutions works too.

| |
\$\endgroup\$
  • 3
    \$\begingroup\$ I get that a lot as well, in fact for me it often works just by saving the image to my local disk without any editing. \$\endgroup\$ – PeterJ May 12 '13 at 1:41
  • \$\begingroup\$ Does it happen when uploading via the URL? \$\endgroup\$ – clabacchio May 12 '13 at 10:22
  • \$\begingroup\$ @clabacchio updated \$\endgroup\$ – jippie May 12 '13 at 10:49
  • \$\begingroup\$ I also had some problems when updating from web, but I don't know exactly the reason. Have you tried on meta.so? \$\endgroup\$ – clabacchio May 12 '13 at 11:26
  • \$\begingroup\$ @clabacchio obviously not \$\endgroup\$ – jippie May 12 '13 at 11:52
  • \$\begingroup\$ I have the same issue with image.frl/i/4cglt4c57oodkl35.png which is a valid APNG image. Any idea? \$\endgroup\$ – Royi Sep 25 '17 at 14:39
2
\$\begingroup\$

From Meta.SO:

After trying and failing a couple of times (and even trying different images), it finally occurred to me that the image was fine, but the original host blocked imgur from accessing it.

And in the answer:

Unfortunately, when it comes to passing a URL to imgur, we can only display what they tell us (which ends up being a 400 error).

So the problem is not about the file type, but about the source site blocking imgur from accessing the image and giving a 400 error.

| |
\$\endgroup\$
  • \$\begingroup\$ Three or four times I've had the same problem with an image already on imgur, for example I tried the following a few times to make sure it wasn't a temporary problem i.stack.imgur.com/FJcUf.jpg (that's a "schematic" a new user just posted). \$\endgroup\$ – PeterJ Jul 11 '13 at 7:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .