2
\$\begingroup\$

I just tried to include a image in a answer and the system didn't let me. I used the same procedure I always do, which is to type ctrl-G, then enter the name of the image file on my disk. When I hit ADD PICTURE, it popped up a window saying "Are you sure you want to navigate away from this page? You have started writing or editing a post. ...". If I try to upload again after that it pops up a different window that says "For security reasons, framing is not allowed ...". I would upload screen shots if I could, but I get the same problem trying to upload images here in meta.

Please fix this.

While you're at it, it would be nice to fix the long-standing bugs in the Add Image dialog. When I type ctrl-G, the Add Image dialog pops up. There is a place to enter the image file name with a BROWSE button immediately to the right of that. The stupid thing though is that you can't type in the file name line. You have to click on BROWSE with the mouse, which then pops up another window the finally does let you type a file name. I really dislike being forced to use the mouse. It slows down the flow and requires concious mental intervention as apposed to typing. This has been broken since the last change to this diaglog maybe a year ago.

Added:

At least some others are not running into this problem, so I'll try to provide some screen shots. Since I can't upload them I'll put them on a server and provide the link here.

Here is the result of trying to add a image into this post: http://www.embedinc.com/temp/b.jpg

\$\endgroup\$
8
  • \$\begingroup\$ Image upload working for me. Which browser? \$\endgroup\$ Commented Sep 3, 2013 at 16:27
  • \$\begingroup\$ @Anindo: Whatever is on this WinXP system. OK, I just checked and it says IE version 8.0. I looked around on the Microsoft site, and that seems to be the latest version you can get for WinXP. \$\endgroup\$ Commented Sep 3, 2013 at 16:56
  • \$\begingroup\$ Olin, could I ask you to try either Chrome or FireFox just to check? \$\endgroup\$ Commented Sep 3, 2013 at 17:33
  • \$\begingroup\$ @Anindo: I don't want to go thru all that installation stuff, with unpredictable results on various settings, then possibly end up with dueling browsers. If the SE developers really need me to try something like that, I can probably do it on a spare machine, but it's not something I want to do unless it is necessary. I'm assuming you're not a SE developer, right? \$\endgroup\$ Commented Sep 3, 2013 at 20:51
  • 1
    \$\begingroup\$ Olin: No I'm not, just trying to help. \$\endgroup\$ Commented Sep 4, 2013 at 3:14
  • \$\begingroup\$ What size is the image you are trying to upload? Does this happen with any image? \$\endgroup\$
    – Oded
    Commented Sep 20, 2013 at 14:28
  • \$\begingroup\$ @Oded: It seems to be all sizes. I just tried with 1024 x 683 and 400 x 267 and both failed. \$\endgroup\$ Commented Sep 20, 2013 at 15:02
  • \$\begingroup\$ OK. I've managed to reproduce this (using a Windows XP virtual machine). \$\endgroup\$
    – Oded
    Commented Sep 20, 2013 at 15:49

3 Answers 3

3
\$\begingroup\$

This is an issue that only presents in IE 8 on Windows XP and has to do with how the JavaScript engine iterates (or rather doesn't) in specific cases.

Fixed in the next build (rev 2013.9.23.1029).

\$\endgroup\$
3
  • \$\begingroup\$ Thanks for fixing this. When will this new version be rolled out? \$\endgroup\$ Commented Sep 23, 2013 at 14:57
  • \$\begingroup\$ @OlinLathrop - I don't have a timescale. We do have a small backlog of changes, so I expect later today (a few hours at most). \$\endgroup\$
    – Oded
    Commented Sep 23, 2013 at 14:58
  • \$\begingroup\$ Confirmed. I can upload images again. Thanks for taking care of this. \$\endgroup\$ Commented Sep 25, 2013 at 14:00
10
\$\begingroup\$

Let's try:

enter image description here

enter image description here

Seems to work for me.

\$\endgroup\$
4
  • 1
    \$\begingroup\$ +1 for Muppets! \$\endgroup\$
    – JYelton
    Commented Sep 3, 2013 at 21:54
  • \$\begingroup\$ Browser version? \$\endgroup\$ Commented Sep 5, 2013 at 2:19
  • \$\begingroup\$ Chrome, the latest version that it auto-updated to. \$\endgroup\$
    – user3624
    Commented Sep 5, 2013 at 2:22
  • \$\begingroup\$ Thanks to "user3624" for making us smile before leaving... \$\endgroup\$
    – radagast
    Commented Sep 27, 2013 at 9:00
3
\$\begingroup\$

I normally use FireFox but maintain a number of virtual machines running XP with all the latest service packs / Internet Explorer etc installed. Using Internet Explorer build 8.0.6001.18702 I also received the framing error although didn't get the message about navigating away:

enter image description here

There is a Meta.SO post about it but that mentions a 2MB file limit, the file I uploaded as per below is only 190kB. Being a virtual machine that I use for testing it's very "clean" and doesn't have any sort of browser plug-ins installed and is rarely used to access the Internet so unlikely to be infected with anything malicious.

enter image description here

\$\endgroup\$
3
  • \$\begingroup\$ Thanks for confirming the problem. I'm still hoping someone from SE says they know the problem and that it will be fixed soon, or provide a workaround for a while. You got the error but were also able to upload images. How did you do that? \$\endgroup\$ Commented Sep 4, 2013 at 12:14
  • \$\begingroup\$ @OlinLathrop, I just captured the error in IE and then came back and uploaded with Firefox. I noticed your comment above about not wanting duelling browsers, although since the MS browser antitrust thing years ago I've never had any problems running multiple browsers. But having said that they should fix it, IE8 is not exactly ancient. \$\endgroup\$
    – PeterJ
    Commented Sep 4, 2013 at 12:24
  • 3
    \$\begingroup\$ @PeterJ ancient is arguable. IE8 is obsolete by two major versions, and the two newest versions have dropped windows XP, which is obsolete by three major versions. The user base for these is shrinking, making support by both Microsoft and third parties like SE less and less worthwhile. \$\endgroup\$ Commented Sep 5, 2013 at 2:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .