0
\$\begingroup\$

I just tried to answer a question by including a schematic in the answer, as I have done often in the past. I use Eagle to draw my schematics, then generate a appropriately sized image file from there, then upload that into the answer.

In the past, I typed CTRL-G, which popped up a dialog that eventually allowed entering the image file name on my computer. The system then uploaded that to IMGUR and added the link to the image at IMGUR to my answer. The upload image interface was a little squirrely, but at least it worked.

I just tried the same thing again, and this time I get a rediculously large IMGUR splash screen, with directions to "Click here" to upload my image. Annoying user interface aside (I already said I want to upload a image, clicking again is just busywork, and worse, forces me to move my hand from the keyboard to the mouse), the problem is this new interface doesn't work. When I click as directed, another popup lets me (finally!) enter the image file name. After entering the file name, it pops away, and leaves me with just the original popup. There is a "Add picture" button in the lower right corner, but clicking that poofs me into never-never land. I get a completely white screen. F5 (refresh) doesn't do anything, and there is no apparent way to get back into the edit window for the answer I am writing. My only option seems to be to kill the browser. When I start a new browser session and eventually navigate back to the edit window, it's in the state it was when I typed CTRL-G. My image isn't there.

Since I can't upload images, I can't show screen shots in this question. I have temporarily put a screen shot of the CTRL-G popup at http://www.embedinc.com/temp/imgur.jpg.

Response to questions:

This machine is running WinXP and I am using whatever the latest version of IE is that runs on XP. I just checked and it's IE 8.0.

Workflow:

  1. CTRL-G. That brings up the "Click here to upload your image" large popup that I show with the link above. It's interesting that this is a little different from what W5VO showed. His says "Drag and drop or click here to upload your image".

  2. Click where it says "click here".

  3. This pops up a file name dialog. I type the file name and hit ENTER. This is a local file on my machine, not out on the web. The exact file name was "c:\temp\b.gif" when I ran into this problem.

  4. I forget exactly, but something for a fraction of a second says something like "uploading", giving the impression the file was uploaded to someplace.

  5. The file name dialog disappears, leaving only the original "click here" popup.

  6. Click on "Add picture" button in the lower right corner. This causes the browser window to go completely white, with no apparent means to continue or getting back to editing the answer.

  7. Kill browser. Start new browser session. Navigate to the edit window for the partially written answer. See that it's state is what it was when CTRL-G was originally typed.

| |
\$\endgroup\$
  • \$\begingroup\$ I think you're going to need to give a bit more info on your setup, such as web browser version and maybe OS. \$\endgroup\$ – W5VO Jul 3 '15 at 16:25
6
\$\begingroup\$

The official line is that IE 8 is no longer supported:

"We support current and previous versions of all browsers with some reasonable amount of market share, but not beta or development versions." –Jeff, paraphrased (source); subsequently reaffirmed by other developers

This means that the versions of IE supported are:

Supported: 11 and 10

This doesn't even take in to consideration that Microsoft no longer support IE 8 or Windows XP.

Therefore, any new features (which this new version of the image upload is one) are not guaranteed to work on older browser versions. The fact that previous updates have worked has probably been just through luck.

Source

| |
\$\endgroup\$
  • \$\begingroup\$ That makes this site not work for XP users, since 8 is the latest version of IE that runs on XP. I'm not going to get a new machine or update the OS just to access SE. It was working before, so clearly it can be done. This phancy pheature creep is both unneccesary and annoying. Just leave things the way they were. It wasn't broken. You are only having a problem because you are making changes for the sake of changes, not because they make anything better. Of course Microsoft wants everyone to buy the latest, but for most uses there is simply no need that isn't artificially created, like this. \$\endgroup\$ – Olin Lathrop Jul 3 '15 at 19:28
  • 2
    \$\begingroup\$ @OlinLathrop well in terms of Operating Systems I'd say that wasn't supported either - especially since it's no longer supported by Microsoft. Oh, I don't really want to hear how you have to use XP for your work. You could use SE on a different machine or do your work in a virtual machine inside a more modern operating system. \$\endgroup\$ – user5957 Jul 3 '15 at 19:58
  • 2
    \$\begingroup\$ Why throw out a perfectly good working machine that does all other things it needs to do? (I say throw out since upgrading the OS is usually more expensive than buying a new machine with the new OS on it.) Then there is the cost of getting used to the new workflow, installing different drivers and maybe tools, etc. It's not free, far from it. New machines I get will run the latest OS, but right now I don't need a new machine other than for such artificial reasons as this one. It's reality out there. Your holier-than-thou attitude is not appreciated. I do use Win7 in a different place. \$\endgroup\$ – Olin Lathrop Jul 3 '15 at 20:27
  • 5
    \$\begingroup\$ @OlinLathrop You can use Chrome or Firefox... both of which still support XP. \$\endgroup\$ – hichris123 Jul 3 '15 at 20:47
  • \$\begingroup\$ @hich: I do have Chrome installed on the XP machine, but don't normally use it due to a more annoying user interface than IE. I don't like having to use the mouse for things that aren't inherently graphical since it's so much slower than keeping your hands on the keyboard. IE is better at this, and I'm more used to the hotkeys it has. I find Chrome browsing slower and therefore more annoying. I may use Chrome more for SE, but that will mean I'll come here less. There is no need for change just for change. Remember that it worked fine on IE 8 just a few days ago. \$\endgroup\$ – Olin Lathrop Jul 3 '15 at 20:56
  • \$\begingroup\$ @OlinLathrop, completely agree on how annoying feature creep gets. Have you tried Firefox on your XP computer? I find it to be more similar to IE than Chrome is (though I do use Chrome at work). \$\endgroup\$ – Mewa Jul 13 '15 at 18:16
  • 1
    \$\begingroup\$ This doesn't answer the question. A simple "They must have added a new feature that borked IE 8" would suffice, if true. \$\endgroup\$ – Passerby Jul 14 '15 at 12:43
1
\$\begingroup\$

As noted by the answer at Problems with SF&F and Seasoned Advice SE CSS a new update to the image upload feature occurred, with many hiccups from a quick google search. Per that answer, most were fixed due to CSS issues between old and new format sites.

Unfortunately the new image upload uses more JavaScript/Ajax than is supported on older browsers. Like IE 8 (Six Years old), or XP (14 years old). Or in my case, Safari 5 and OSX 10.6.8. A sign of the times, browsing specifications have moved past our obsolete/antiquated programs. Google did the same, intentionally breaking support for older browsers. SE has not broken it intentionally, just moved on. For myself, I can't upload pictures, but I can still click on the Link from the web option in the image feature.

| |
\$\endgroup\$
0
\$\begingroup\$

When I click on the "add image" icon, or press Ctrl-G, I get the following dialog: This image was pasted into the input dialog from the clipboard via ctrl-v

I can get an image to upload by four methods:

  1. Copy the image from an image editing program (Paint) and use ctrl-v on the webpage
  2. Drag the image icon from a folder into the blue dashed window area (this appears to be the new feature)
  3. Click on the blue dashed area to open the file browser, at which point I get a file browser. Navigate to the relevant image file and click Open
  4. Click on the link from the web bit to provide a web address.

Now I can't reproduce your bug of files not uploading, and I'm having difficulty understanding your workflow (and how it was impacted). Were you typing the file name into the entry box, or uploading the file to a server and then copying the link?

I used the image from www.embedinc.com/temp/imgur.jpg

| |
\$\endgroup\$
  • \$\begingroup\$ See addition to question. \$\endgroup\$ – Olin Lathrop Jul 3 '15 at 17:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .