26
\$\begingroup\$

You may have noticed some updates to the design lately, they are part of a SE network-wide update to a new base css framework.

The updates allow us to:

  • Have sharper / more beautiful design on retina displays
  • Fix layout bugs
  • More easily add new features to all of our sites in the future

After a discussion with the community, the logo was also updated (I chose the most usable icon in this discussion).

But more importantly, it gives you access to the new profile!

If you see any bugs please let us know in the form of answers (to this post) that illustrate one particular thing at a time.

Thanks!

\$\endgroup\$
  • 8
    \$\begingroup\$ What makes a icon "usable". People were generally against anything that didn't look like a real schematic symbol. I'd be happy to make the transistor symbol more "usable" if you tell me what the criteria are. \$\endgroup\$ – Olin Lathrop Oct 6 '15 at 10:51
  • 4
    \$\begingroup\$ Call me an carpenter's eyed autist, but the diode symbol is not symmetric and some lines are not straight or at right angles that would be in a real schematic symbol. Also at the top the circle is one pixel higher than at the bottom, with respect to the text. \$\endgroup\$ – jippie Oct 6 '15 at 11:27
  • 10
    \$\begingroup\$ I liked the old design (how the page looked) better. And now it looks like the rest of the forums on the internet. \$\endgroup\$ – Nazar Oct 6 '15 at 11:52
  • 5
    \$\begingroup\$ I think an icon should be unique and should bring the thing connected with it immediately to mind (I haven't studied marketing, so I could be entirely wrong). A simple real schematic symbol is neither unique nor will it connect to EE.SE (could be used anywhere), so this tilted diode in a circle is (in my opinion) actually quite nice: it's simple, it's somehow related to EE and unique enough to be connected with EE.SE. Maybe we start another "Design the EE icon contest" over a longer period of time so everyone can post their opinion and use the current one as long as the contest is ongoing. \$\endgroup\$ – Arsenal Oct 6 '15 at 13:25
  • \$\begingroup\$ The bottom wire of the icon is "cut" at an angle but the top one is "cut" at a right angle, making them inconsistent. I think it would look better if it wasn't tilted anyway. If it points upward it looks a bit like the upvote icon. Either way, this is much better than the proposed icon. \$\endgroup\$ – Null Oct 6 '15 at 13:41
  • 5
    \$\begingroup\$ I wonder if for other icons (starred question, accepted tick etc.) we could come up with more schematics like ones. \$\endgroup\$ – PlasmaHH Oct 6 '15 at 13:54
  • 8
    \$\begingroup\$ I gotta say I agree with @Naz. I definitely preferred the older style, and I loved how the buttons were ICs. Now it's all gone, and everything looks so plain and ugly. Just my $0.02 \$\endgroup\$ – DerStrom8 Oct 6 '15 at 16:27
  • 1
    \$\begingroup\$ Is there any particular reason why there's no whitespace between the site logo and the window border? It makes it look as though there should be more to the left even though the hscrollbar is already all the way to the left. \$\endgroup\$ – Ignacio Vazquez-Abrams Oct 6 '15 at 18:31
  • 3
    \$\begingroup\$ I agree the old 'look' had to be improved. However, I prefer subtle and sophisticated designs, not ones where I gasp when I look at it. I like designs which are almost invisible because they work so very well. I prefer sans serif titles, labels, and code, and serif text. This sans serif everywhere looks like a 'cool' manual or report from the late 80's/early 90's when people thought 'modern' must = san serif. However, IMHO they took years to re-learn about usability, and that essentially you shouldn't even notice the type face before the content. I'll wait for a few years, and hope :-( \$\endgroup\$ – gbulmer Oct 6 '15 at 20:04
  • 2
    \$\begingroup\$ Nooooooooo. I want back the ICs and the breadboard:( Seriously: How cool was this? \$\endgroup\$ – totymedli Oct 19 '15 at 21:08
  • \$\begingroup\$ Where is Electropus :-) meta.electronics.stackexchange.com/questions/993/… (Please don't take this too seriously, I like the new design quite a lot!) \$\endgroup\$ – zebonaut Oct 20 '15 at 13:20

13 Answers 13

20
\$\begingroup\$

I updated the font family for:

  • questions title
  • answers title
  • question body
  • comments

to "Verdana, "Bitstream Vera Sans", "DejaVu Sans", Tahoma, Geneva, Arial, Sans-serif" (the font stack chooses the 1st one, if you don't have it it goes to the 2nd and so on.)

It should fix this issue for everyone, here is an example: Il1 & CEIlIllIl45. It will be live after our next production build.


Oh well, guess no one needs to distinguish I and l anyways ...

enter image description here

\$\endgroup\$
  • 2
    \$\begingroup\$ Maybe you should use Il1 formatting when the difference is important. \$\endgroup\$ – Dmitry Grigoryev Oct 6 '15 at 12:23
  • 5
    \$\begingroup\$ @DmitryGrigoryev: maybe tell that to all the people that post their first questions (or answers) here without knowing that this might be an issue. \$\endgroup\$ – PlasmaHH Oct 6 '15 at 13:00
  • 3
    \$\begingroup\$ I wish that would be the main issue of first posts! \$\endgroup\$ – Dmitry Grigoryev Oct 6 '15 at 13:03
  • 1
    \$\begingroup\$ @DmitryGrigoryev: So because we have more important issues it doesn't hurt to add potential for minor issues? \$\endgroup\$ – PlasmaHH Oct 6 '15 at 13:04
  • \$\begingroup\$ To be honest, not only the issue seems minor to me, but I actually have never been bothered by it at all, not on a single SE site. I can't ever remember on which site those symbols are visually different. \$\endgroup\$ – Dmitry Grigoryev Oct 6 '15 at 13:19
  • 1
    \$\begingroup\$ @DmitryGrigoryev: On a lot, just go browse around and look at the I. The former design on EE.SE had them different too. Stacks like math.SE have it too. I have seen this causing issues every now and then, and since there are fonts like source sans pro available, it shouldn't be too big of an effort to do it right instead of changing the font to a worse one (who complained about the old one anyways?) \$\endgroup\$ – PlasmaHH Oct 6 '15 at 13:36
  • \$\begingroup\$ I admit I didn't really consider that I may be used to good things so I don't see bad things coming. But still, if someone is to post an ambiguous part number here, I see myself copy-pasting it into google rather than trying to read it aloud. \$\endgroup\$ – Dmitry Grigoryev Oct 6 '15 at 13:44
  • \$\begingroup\$ l think this is reaIIy bad as weII. At Ieast 1 is distiguishabIe. But maybe I'm just a bit strange when it comes to fonts and reading and stuff. The old one had terrible O0o (you complained) and numbers were all over the place (Olin complained and I support that)(they are fine if a single digit is printed but not for longer values). \$\endgroup\$ – Arsenal Oct 6 '15 at 13:44
  • \$\begingroup\$ @DmitryGrigoryev: and then there are the people at work that read EE.SE on their phones and do the quick google for the datasheet/component on the computer they sit at. \$\endgroup\$ – PlasmaHH Oct 6 '15 at 13:49
  • 2
    \$\begingroup\$ IMO, this is a more serious issue than how the logo looks. For an engineering sight we need an un-ambiguous font. \$\endgroup\$ – Tut Oct 6 '15 at 14:30
  • 2
    \$\begingroup\$ The serif font like in the previous design suited EE.SE better, I think. \$\endgroup\$ – Nick Alexeev Oct 6 '15 at 18:07
  • \$\begingroup\$ Il1 can either be told apart via a) context ("Looo" ohms?) or b) code blocks (If you're not wrapping your code in ` or a 4-indent then shame on you.) \$\endgroup\$ – Nick T Oct 7 '15 at 19:55
  • 1
    \$\begingroup\$ @NickT: I am sure everyone here, especially those that are posting new questions, will have that in mind when posting part numbers/markings like CEIlIllIl45 \$\endgroup\$ – PlasmaHH Oct 8 '15 at 7:37
  • \$\begingroup\$ I'm looking for a solution, one idea is to change the post and comment font family, but I need to be sure I choose the right one. In other words, once I'll have a strong solution, it'll be fixed. But I can't do it without changing the font family... so expect to see some change. \$\endgroup\$ – Stéphane Oct 8 '15 at 8:45
  • 2
    \$\begingroup\$ Am I the only one that thinks the site is harder to read now than ever? \$\endgroup\$ – Matt Young Oct 8 '15 at 17:01
16
\$\begingroup\$

I pushed a fix, it will be live after our next production build.


Couple of graphical things which will get annoying.

  1. The vote arrows don't line up with their sticks - its off by a pixel (which doesn't sound a lot, but for something which is only 20 pixels wide it is quite noticeable!). It's probably just because the point of the arrow is 1px wide and the line is 2px wide, so it can't render it in the middle - or at least not on IE.

Vote arrows

  1. Ignoring for a moment what the icon pictures (we were leaning towards the FET it seemed, but diode is ok). It was symmetrical at one point in its life - seems it got cropped a bit asymmetrically so the bottom line got bevelled and the top isn't. Just sayin'.

Icon vs Original Icon


Aside from that, I like that we have the new user pages, and the rest doesn't look bad - change takes getting used to.

\$\endgroup\$
  • \$\begingroup\$ I doesnt have that one pixel offset here (chrome, ff) so it might be an IE issues, which version? \$\endgroup\$ – PlasmaHH Oct 6 '15 at 13:52
  • \$\begingroup\$ Hmm on Opera 22 the vote buttons don't look off so pronounced but they actually seem to have some sort of problem - I think it's because the triangle has an antialising border around it which makes the stroke look different and not connected. \$\endgroup\$ – Arsenal Oct 6 '15 at 13:53
  • \$\begingroup\$ It's off in Firefox too. The accept icon doesn't look quite right aswell, but at this moment I cannot be bothered to double check that. \$\endgroup\$ – jippie Oct 6 '15 at 14:05
  • \$\begingroup\$ I've added a zoom-in of mine and your arrows, they look quite differently. \$\endgroup\$ – Arsenal Oct 6 '15 at 14:10
  • \$\begingroup\$ It is wrong (offset to the left) for me in chrome 45.0.2454.101. (At least here on meta, I've not checked the main site). Also there looks to be some form of blur effect on the line, that is not present on the triangle. The latter is some form of SVG rendering artifact, perhaps due to GPU acceleration? \$\endgroup\$ – Kevin Cathcart Oct 6 '15 at 14:43
  • \$\begingroup\$ @KevinCathcart I don't know how the stuff gets rendered in detail, but the line is 2 pixels wide but has a X coordinate of 18.5px in the original SVG, so I guess it's prone to some form of rendering artefacts. \$\endgroup\$ – Arsenal Oct 6 '15 at 15:02
  • \$\begingroup\$ The offset on Safari 9 isn't as pronounced as yours, but I do see it a little. \$\endgroup\$ – Passerby Oct 6 '15 at 15:09
  • \$\begingroup\$ The rest of the new look is very nice, but the icon lines need to match. \$\endgroup\$ – Houston Fortney Oct 6 '15 at 19:58
  • \$\begingroup\$ More importantly, why are those up/down symbols some strange kind of op amps with only one input? Typical op amps have two inputs V+ and V- which obviously stands for vote + and vote -. \$\endgroup\$ – Lundin Oct 8 '15 at 7:42
  • \$\begingroup\$ @Lundin that symbol is used as a buffer in digital logic circuits \$\endgroup\$ – Xcodo Oct 8 '15 at 12:51
11
\$\begingroup\$

I updated the favicon, it will be live after our next production build.


Minor problem, but a little bit annoying is that the background of the new icon is not transparent.

It can be observed:

in the flair, where other icons have transparent background:

enter image description here

and in a browser's tab:

enter image description here

\$\endgroup\$
  • 2
    \$\begingroup\$ Also on the flair it's quite difficult to see it's a diode. I am pro transparent background, but am worried it will be even less clear. So, please consider that as well. \$\endgroup\$ – user17592 Oct 7 '15 at 15:12
  • \$\begingroup\$ It's possible to make them transparent and yet nicely visible. I had made favicons when I drew the logo. I've uploaded them here: Main Favicon, and Meta Favicon \$\endgroup\$ – Tom Carpenter Oct 8 '15 at 1:38
  • 1
    \$\begingroup\$ I like the new favicon - very visible, very distinguished and transparent. \$\endgroup\$ – Arsenal Oct 8 '15 at 14:21
5
\$\begingroup\$

If you can add more electrical like symbols, then it will be awesome. Earlier at the home page, there was IC's on the breadboard which was cool. So try adding that, if possible.!

\$\endgroup\$
  • 1
    \$\begingroup\$ We shouldn't encourage people to use breadboards anyway... it is horrible, error-prone junk that cost about as much as a simple solder iron. \$\endgroup\$ – Lundin Oct 8 '15 at 7:47
  • \$\begingroup\$ @Lundin I agree but that is just for designing purpose and making the Electronics.SE more cool. I am not saying to use breadboard only, instead we can use more electrical symbols and tools used in electrical domain. \$\endgroup\$ – Aircraft Oct 8 '15 at 8:21
4
\$\begingroup\$

You can't tell what the favicon is on a non-retina screen nearly as easily as other comparable favicons. On most screens, it looks like a small red dot at a comfortable reading distance. For example, compare the screenshot size of the identifying features of the new favicon to other random sites. (Chrome, but it appears in Chrome Mobile and FireFox as well):

EE.SEHADYTXKCDDigikey

You can't easily tell that the EE.SE icon is a diode, and that's not just because you have limited pixels.

enlarged favicon

  1. A 1.5-pixel perimeter is "wasted" to show the "leads" further away. This is not as important as being able to identify what the symbol is.
  2. The anti-aliasing causes an indistinct image in the center.
  3. The odd rotation results in higher amounts of destructive anti-aliasing (regardless of opinions on the rotation).
  4. The triangle and perpendicular line are the key identifying elements, and these need to be emphasized better.

I would recommend reducing the border given to the circle to the point that the circle fills the favicon more (or even completely). The leads are not necessary in such a small icon, and removing them may help with clarity. The triangle can be filled-in with white, if that helps. The actual lines should be larger than they are now, but scaling the whole image may be enough.

As an aside, please note that these are schematic symbols that are specifically and internationally recognized. There are very few ways to draw a diode correctly (1). It's like making a STOP sign with a pentagon instead of an octagon. This is why people are complaining when you take artistic license with the symbol.


(1): For the pedantic EE's in the crowd, I'm talking about a standard diode, not anything fancy. Yes, I know there are other types of diodes, and they are drawn differently.

\$\endgroup\$
  • 2
    \$\begingroup\$ I'm with you here, +1. People generally wanted a real schematic symbol, and this isn't because 1: it's tilted and 2: it has a circle around it. It looks like a graphic artist's idea of a electronics symbol, which is apparently exactly what it is. Stephane picked what he liked, apparently without any regard to how the members voted on various symbols. Actually I'm not complaining about him doing that as SE has every right to do with their site as they wish. What bothers me is the sham of soliciting opinions from members. Do what you want, but then don't insult us by asking our opinions. \$\endgroup\$ – Olin Lathrop Oct 10 '15 at 13:24
  • \$\begingroup\$ Is a 1920x1080 24" monitor considered a retina display? I have no trouble at all identifying that icon. \$\endgroup\$ – Arsenal Oct 10 '15 at 20:15
  • \$\begingroup\$ @Arsenal all my screens are 1920x1080, and I have difficulty regardless of the physical screen size. \$\endgroup\$ – W5VO Oct 10 '15 at 22:37
  • \$\begingroup\$ Strange, maybe it's my eyes built in blur which helps in this case. \$\endgroup\$ – Arsenal Oct 11 '15 at 7:53
  • \$\begingroup\$ @Arsenal I think my point is more that at a distance that is normally OK for distinguishing the icons, I cannot distinguish the new icon as much more than a red dot. \$\endgroup\$ – W5VO Oct 11 '15 at 19:59
4
\$\begingroup\$

The weekly email still uses the old style, an example from today is below.

Are there plans to update this also?

weekly email

\$\endgroup\$
3
\$\begingroup\$

In safari on a retina display the small icon is off-centre:

enter image description here

Not sure about other machines.

My 2c:

As for icons, some from here: https://icons8.com/web-app/category/all/Industry

enter image description here

enter image description here

enter image description here

My personal criticisms:

  • The logo is unbalanced. The centre of gravity of the diode icon is in the lower half, while the centre of gravity of the words is in the upper half.
  • The spacing of the letters in the bottom word is too big.
  • The gap between the icon and the letters is too small.

Here is an example of what I think is a better executed icon from my uni:

enter image description here

\$\endgroup\$
  • \$\begingroup\$ I didn't expect to see the JCU logo there. Well played. (JCU BEng/BSc 2010.) \$\endgroup\$ – Li-aung Yip Oct 9 '15 at 4:24
  • \$\begingroup\$ Seems to be a safari thing, lines up pretty well on IE and Firefox \$\endgroup\$ – Tom Carpenter Oct 9 '15 at 16:56
2
\$\begingroup\$

Minor issue, the review queue filter link is not lined up with the rest of the text:

enter image description here

\$\endgroup\$
2
\$\begingroup\$

Vote arrow has fine border lines (safari, retina)

enter image description here

\$\endgroup\$
2
\$\begingroup\$

I just saw on another SE site an ad for Electrical Engineering, but that still uses the old logo. I consider this to be a . However, I must say I like the new design, it looks fresh. Picture of the ad:

enter image description here

Edit: I haven't seen this again, but please consider adding a status tag if this is fixed or fix this.

\$\endgroup\$
1
\$\begingroup\$

It's rather dissappointing that you asked for feedback, lots of people put significant effort into proposing options, lots of votes were cast, then you went and did what you felt like anyway.

It's your site and you have a right to do what you want, but then please next time just do it and not have everyone waste their time and then feel ignored when you do what you want anyway.

It's also dissappointing that it's been over a day, and there has been no official response to any of the issues raised.

Again, if you're going to do what you want and ignore us, then please at least do us the courtesy of not pretending to get our input. I'd have less problem with that than what you actually did.

\$\endgroup\$
  • 5
    \$\begingroup\$ They changed the logo upon the request of many. They aligned digits (0123456789) vertically, which was specifically your request. What is the problem? That they didn't choose the exact logo you requested? Do you have any idea how many sites are getting an updated design at the moment? \$\endgroup\$ – user17592 Oct 8 '15 at 6:04
  • 5
    \$\begingroup\$ The icon I used was actually given by a member of the community, I changed what I did to have something realistic, just like the community asked. I didn't choose yours because it was hard to use at small sizes. It's not "my" site, it's the community's site and we're doing our best to listen to this community and take design decisions that actually work. I know sometimes it may sounds like we're not listening, but that's false. I'm trying to listen to this community as much as I can but also create a logo that will work in all situations. \$\endgroup\$ – Stéphane Oct 8 '15 at 7:30
  • 2
    \$\begingroup\$ @Camil: The top voted icons were a NPN transistor and a FET. Very few liked the diode, and pretty much universally everyone wanted a real schematic symbol. Nobody would put a circle around a diode in a schematic, and they certainly wouldn't tilt it at a odd angle like that. \$\endgroup\$ – Olin Lathrop Oct 8 '15 at 10:36
  • 2
    \$\begingroup\$ This is not a democracy. And in any case your claim that they "did what they felt like anyway" is really not accurate. \$\endgroup\$ – user17592 Oct 8 '15 at 13:36
  • 1
    \$\begingroup\$ There are about 23 ways to draw a transistor, all requiring more detail than a diode. I'm one for simplicity. Maybe BJTs are fairly unambiguous, but they're so analog (plus require finer detail that could get lost when shrunk down ) \$\endgroup\$ – Nick T Oct 8 '15 at 16:30
  • 1
    \$\begingroup\$ I support your position. Really. They do whatever the heck goes on their mind, pretending to ask input. This is not the first time and won't be the last. Same happens across other websites. Promises made and never delivered, inputs asked and ignored... This is the mais issue. \$\endgroup\$ – Ismael Miguel Oct 8 '15 at 20:52
  • \$\begingroup\$ The MOSFET had 7 lines, the BJT had 6, the diode 6. \$\endgroup\$ – geometrikal Oct 9 '15 at 11:50
  • 2
    \$\begingroup\$ @geometrical indeed, and also with the MOSFET being all horizontal and vertical lines (except the circle) it scales down well - essentially at 16px x 16px you make each like 1px wide, then as it scales up the thickness is always an integer number of pixels (so doesn't blur). \$\endgroup\$ – Tom Carpenter Oct 9 '15 at 12:45
  • \$\begingroup\$ I remove a downvote, but I think they select the best available. Simple and meaningful. I disagree that site it is belongs to a person or a small group. Anyway it is still extremely attractive and very popular. So prepare for the new logo contest for the next time of change...Regards \$\endgroup\$ – GR Tech Oct 18 '15 at 11:53
1
\$\begingroup\$


The toolbar button that linked to the schematic editor seems gone from the question-asking page. Is that by design?

Before After

EDIT: Obvious coffee-deprived report from me. It's indeed there on the main site.

enter image description here

\$\endgroup\$
  • \$\begingroup\$ I can still see it on the main site, correct me if I'm wrong, but it was on the main but not on meta. Things are still the same right ? :) \$\endgroup\$ – Stéphane Oct 8 '15 at 7:27
  • 2
    \$\begingroup\$ You are indeed correct. False alarm! \$\endgroup\$ – Fizz Oct 8 '15 at 7:29
1
\$\begingroup\$

Could you also do something about the "Questions", "Tags", "Users", ... buttons on the top right side of the website. I am guessing they're trying to resemble resistors, but they are just so simple and empty. Like black and white TV...

Maybe try adding some colors to them or around them (maybe something like bands on a real resistor). Change their font, make it a bit more playful, ... Every other SE site, even those in beta have a more modern looks to those buttons.

I am not really a graphics designer and cant think of a elegant design of the top of my head. But please try to look into this...

\$\endgroup\$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .