5
\$\begingroup\$

When embedding a CircuitLab schematic the schematic is scaled to a constant width regardless of the complexity of the diagram. This causes questions and answers with multiple schematics to become unwieldy, sometimes creating a perverse incentive to not illustrate a circuit with a schematic diagram.

This exact issue was asked about almost three years ago, and no notable improvement has emerged. Is there anything that can be done to either fix the issue or work around it?

| |
\$\endgroup\$
  • \$\begingroup\$ It might be worth putting a comment under the answer on that question to see if they respond. I noticed they were active on Stack Overflow a few days ago and the pings work across all sites. \$\endgroup\$ – PeterJ Feb 1 '16 at 11:18
  • 2
    \$\begingroup\$ A workaround I have used is to draw a wide box around the circuit. Anything that adds width to the image will do. \$\endgroup\$ – Tut Feb 1 '16 at 11:53
  • 2
    \$\begingroup\$ Well.. could start making use of the fact imgur links can be resized: i.stack.imgur.com/TbYch.png --> i.stack.imgur.com/TbYchs.png The real question is whether the "s" can be added by default \$\endgroup\$ – JonRB Feb 1 '16 at 12:36
  • \$\begingroup\$ @JonRB I didn't kow that, interesting. Would this interfere with editing schematics? \$\endgroup\$ – jms Feb 1 '16 at 12:49
  • \$\begingroup\$ just checked... it does, but the "s,m,l" suffix can be removed. I wonder if it is worth having this as an option. extra comments during edit so ppl remember. I agree large cct are annoying but it is easy to forget you put a "m" to make a medium image \$\endgroup\$ – JonRB Feb 1 '16 at 12:55
  • \$\begingroup\$ @JonRB Use the "t" suffix rather than "s". "s" crops the image to a square (therefore removing parts of a rectangular diagram) whereas "t" retains the proportions of the original image and doesn't crop it. \$\endgroup\$ – dim Nov 28 '16 at 11:10
  • \$\begingroup\$ There was already a workaround posted there in 2013 (and also again here). When you ask for a workaround, are you asking for a different workaround? If so, what would it have to do to be better than the 2013 workaround? \$\endgroup\$ – uhoh Mar 21 '17 at 6:54
6
\$\begingroup\$

I often put a small section of wire on the right hand side to have the auto-scaling work out to a reasonable sized diagram.

| |
\$\endgroup\$
0
\$\begingroup\$

Another trick is to place some small text in the lower right corner (take it as a sort of signature, if you want, e.g. your initials).

You can put enough horizontal space between that text and your actual circuit so that the result scales well and doesn't appear huge.

| |
\$\endgroup\$
-4
\$\begingroup\$

The workaround is simple. Design your schematic wide, not tall. Circuitlab has a minimum whitespace/deadspace around the objects that it uses to create the image. And since Stackexchange scales an image to the maximum width of the post table size, simply making the image long-wise will prevent that.

| |
\$\endgroup\$
  • 2
    \$\begingroup\$ If you want your schematic to conform to the usual conventions, its orientation is often not an option (in particular for very small schematics, for which this sizing problem is even more annoying). For example, a resistor divider between supply and ground is expected to be vertical. \$\endgroup\$ – dim Jun 1 '16 at 19:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .