1
\$\begingroup\$

Since I've only accessed SE from my mobile devices for the last month now, I've begun noticing some interesting erm "characteristics" of the CircuitLab links on this site.

  1. If browsing with "Request Desktop Site" disabled, I always get a "CircuitLab doesn't work on touch devices" message (wording may not be accurate, but same intent).

  2. If I try to open CircuitLab while writing an original post with "Request Desktop Site" (RDS) enabled, I usually get that message, but once i a while it opens (sorry, haven't tried to verify functionality yet, but it opens).

  3. If I try to open CircuitLab while editing a post, or by clicking the "modify schematic" link, it usually opens (still haven't tried actually doing anything).

So... My question(s):
Is CircuitLab rwally incapable of working on touch-based input devices?

  • If yes, then why the "opening glitch" & can we get that fixed?
    • How can we override if using a USBotg device with an attached mouse?
    • Can we put some pressure on CircuitLab to "make it compatible"?
  • If no, can we disable/workaround the code CircuitLab uses to identify "touch devices" to skip that message & "get some work done"?
| |
\$\endgroup\$
  • 2
    \$\begingroup\$ Circuitlab is run in an iframe, so everything you see happen is from CircuitLab's servers, same as if you went directly to their site. So this is not a EE.SE question. \$\endgroup\$ – Passerby Feb 26 '16 at 8:23

You must log in to answer this question.

Browse other questions tagged .