4
\$\begingroup\$

Is anyone else having trouble with CircuitLab for the last 24 hours? I can't save any schematics. I'm using Chrome on Windows 10 but checked with FF and Edge. I thought yesterday's maintenance shutdown might fix it but, alas, no.


24-hours later:

CircuitLab functionality seems to have been restored. I haven't found any explanation for the fault. Thanks, all, for the feedback.

\$\endgroup\$
  • 2
    \$\begingroup\$ Someone thinks this is an inappropriate place to ask. Would you care to explain why? \$\endgroup\$ – Transistor Jul 31 at 21:34
  • \$\begingroup\$ Downvotes in meta don't (or anyway, shouldn't) mean it's a bad question. They mean a "no" answer to the question. \$\endgroup\$ – The Photon Jul 31 at 22:44
  • 2
    \$\begingroup\$ Yeah, but it still probably shouldn't be down voted. Just because you don't have an issue doesn't mean that there isn't an issue. \$\endgroup\$ – W5VO Jul 31 at 23:46
  • \$\begingroup\$ I don't think downvoting a question on meta is appropriate if you don't agree with it. You should downvote an answer. \$\endgroup\$ – pipe Aug 1 at 18:04
  • 1
    \$\begingroup\$ @ThePhoton No, that is wrong. The only time we recommend downvoting to show disagreement is for feature requests. \$\endgroup\$ – Catija Aug 2 at 5:47
  • \$\begingroup\$ IS this solved now then? Because I have had issues for a while. Usually get too frustrated and leave comments on questions rather than answer them lol \$\endgroup\$ – MCG Aug 5 at 8:16
5
\$\begingroup\$

It's not just you...

I've noticed this issue yesterday as well.

I pulled up Firefox's terminal debugger. Whenever I "save and upload" a schematic, the JSON response loops indefinitely and it appears to be stuck in some status:wait status.

Below are the XHR responses... and it looks like something from CircuitLab isn't communicating to EE.SE properly. My theory is that EE.SE is rejecting traffic from CircuitLab.

enter image description here

\$\endgroup\$
4
\$\begingroup\$

Not just today — I've been experiencing this issue intermittently for several weeks now. I'm using Firefox on Ubuntu.

It's gotten to the point where I "select all" and copy my schematic to the clipboard before trying to "Save and Insert" — at least that way, if it crashes and burns, I have a chance to open a new tab and try again without having to redo everything from scratch.

\$\endgroup\$
  • \$\begingroup\$ I was doing the same thing. I lost the schematic on a reboot but the problem wasn't at my end. \$\endgroup\$ – Transistor Aug 1 at 18:20
  • \$\begingroup\$ I think the issue relies on the server maintenance that SE had. We probably need to contact the backends and ask them what changed. Did they forget to whitelist traffic from our plugin that's unique to only EE.SE? There seems to be improper data transfer from CircuitLab to EE.SE where there's probably response from CircuitLab but I think EE.SE isn't getting that response. \$\endgroup\$ – KingDuken Aug 1 at 18:32
  • \$\begingroup\$ Is anyone still encountering this? I've been unable to reproduce it over the past couple of days. cc @KingDuken \$\endgroup\$ – Shog9 Aug 6 at 21:37
  • \$\begingroup\$ @Shog9 It should be fixed now since last week. Shortly after I submitted a ticket for you all, the problem was resolved. Probably just pure coincidence. \$\endgroup\$ – KingDuken Aug 7 at 14:31
3
\$\begingroup\$

Based on the network logs in KingDuken's answer, it appears that CircuitLab's server was having some issues and providing a response that the front-end didn't know how to handle.

It appears to be working now. Hopefully it stays that way...

There's also a lengthy delay while the image is uploaded to imgur, but that does complete successfully after a few seconds. Not much we can do there, I'm afraid.

\$\endgroup\$
  • \$\begingroup\$ Thanks. What's the status-norepro tag you added to my question. \$\endgroup\$ – Transistor Aug 7 at 14:39
  • \$\begingroup\$ It means we can't fix it because it's not happening right now, but we can revisit if it reoccurs. \$\endgroup\$ – Shog9 Aug 7 at 14:44
  • \$\begingroup\$ Ah, status-non-reproducible then. \$\endgroup\$ – Transistor Aug 7 at 14:48
  • \$\begingroup\$ Yep! There's supposed to be a bit of text that explains that, but... Looks like it's broken. That, at least, we can fix! \$\endgroup\$ – Shog9 Aug 7 at 15:25
0
\$\begingroup\$

It worked for me in the afternoon, however there have been times in the past few weeks where it took several minutes to finish converting the picture after the circuit was saved.

\$\endgroup\$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .