4
\$\begingroup\$

This question uses an ASCII diagram and has the verilog tag.

To avoid syntax highlighting, I used the <!-- language: lang-none --> directive. Per the SO FAQ,

To specify that you don't want any syntax highlighting for a code block, use
<!-- language: lang-none -->

this should cause the highlighting to dissapear.

It did, in the preview:

preview

Note: this is a dummy edit a little more than 5 minutes after the initial edit, which also displayed the bug

But it didn't take when I saved the edits:

actual

Why is this?

\$\endgroup\$
4
  • \$\begingroup\$ Looks like it also failed to take on electronics.stackexchange.com/q/13718/857 \$\endgroup\$ – Kevin Vermeer Sep 30 '11 at 16:30
  • \$\begingroup\$ And electronics.stackexchange.com/q/19582/857 - better stop for a while.... \$\endgroup\$ – Kevin Vermeer Sep 30 '11 at 16:31
  • \$\begingroup\$ It seems to me that automatic syntax highlighting is a bad idea. It might marginally help in some rare cases, but probably will cause more trouble than it will help. People shouldn't be posting long code here anyway, and syntax highlighting doesn't add much to short code snippets. \$\endgroup\$ – Olin Lathrop Sep 30 '11 at 20:12
  • \$\begingroup\$ @OlinLathrop, we support firmware troubleshooting, why not allow people to post long snippets of code? \$\endgroup\$ – Kortuk Jan 23 '12 at 16:16
1
\$\begingroup\$

I have absolutely no idea what was broken here. It works now, so something has changed, but I don't know what. I even compiled and ran the code as it was back when you encountered this issue; still no luck.

I'll tag this , not because I'm saying you were imagining this (you obviously weren't), but because I really can't reproduce it. If you see this again, please let me know.

\$\endgroup\$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .