2
\$\begingroup\$

When you are typing a new comment or editing an existing comment, if you @lert 2 people you get the warning saying you can only @lert 1 person. This is of course by design.

However, if you remove the @lert of the second person within 5 seconds and then hit the button to submit the comment you receive an error saying you can only comment once every 5 seconds.

I believe the code that establishes having submitted a comment should come after the code that checks to see if you are @lerting 2 people. That way once the @lert is fixed you wont get the 5 second error message.

\$\endgroup\$
  • \$\begingroup\$ It's perfectly OK to bring this up on meta.electronics, (It's appeared on meta.gaming before here), but it's been brought up on meta.stackoverflow many times before: here, here, here, here, here, and here. \$\endgroup\$ – Kevin Vermeer Nov 18 '11 at 13:44
  • 1
    \$\begingroup\$ @KevinVermeer If there are so many posts maybe they should fix this simple bug :-). But to your point, I don't ever think to look at other Metas since I am not active on any of their sites. \$\endgroup\$ – Kellenjb Nov 18 '11 at 13:49
  • \$\begingroup\$ @Kellenjb: meta.stackoverflow is the Meta for all sites, though. \$\endgroup\$ – endolith Nov 18 '11 at 16:40
  • \$\begingroup\$ @Kevin: It's easy to say to go to other meta sites, but frankly I don't fully understand the whole structure. Whenever I do try go to other parts of this site, I get error messages. If I remember right, it has something to do with logins. It won't accept my existing login, but I don't want to create a new account just to add a comment to a meta-meta question. If one login worked everywhere, maybe I'd use the whole site more. \$\endgroup\$ – Olin Lathrop Nov 18 '11 at 17:23
  • \$\begingroup\$ @OlinLathrop - I wasn't suggesting that you need to go to other sites, but your existing login should work on other sites. You can log into your Stack Exchange account using your OpenID, you then need to associate your account with any sites you're interested in. They don't assume that everyone is interested in, for example, Quantitative Finance, Japanese Language, or Role-playing Games, so you don't have profiles there. \$\endgroup\$ – Kevin Vermeer Nov 18 '11 at 18:17
  • \$\begingroup\$ To login to, say, Stack Overflow, visit the page and click log in or browse directly to stackoverflow.com/users/login. Click the button for your OpenID provider - don't click "To create a new Stack Exchange account click here." You're using Stack Exchange OpenID, so click the first button. Is that what produces an error? If so, we can investigate it further, though we'd like to keep you all for ourselves! \$\endgroup\$ – Kevin Vermeer Nov 18 '11 at 18:17
  • \$\begingroup\$ @Kevin: I just tried clicking one of the links to meta.stackoverflow in your first comment. I tried to add a answer just to see what would happen (I was going to abort before saving the answer). I got the please log in screen. That is confusing in itself because I am already logged in. Anyway, I clicked on the stack exchange box and got a screen that asked me to log in, but no place to actually enter the information. I tried to take a screen shot to show you, but the browser hung and I had to kill it and start new session to type this comment. \$\endgroup\$ – Olin Lathrop Nov 19 '11 at 14:37
  • \$\begingroup\$ @Olin - you're not still using IE5 are you? ;-) \$\endgroup\$ – Oli Glaser Nov 21 '11 at 15:28
  • \$\begingroup\$ I just tried to login at meta.stackoverflow.com out of interest, and I couldn't figure out what my Open ID was to login manually (I got a box to login, tried my user name here, and the open ID mentioned in my "logins", but neither worked) Anyway, I refreshed the page and clicked on the "log in with stack exchange" logo and that worked. \$\endgroup\$ – Oli Glaser Nov 21 '11 at 15:40
  • \$\begingroup\$ To all of you, I say this, why not just use an openID from someone like google. \$\endgroup\$ – Kortuk Jan 23 '12 at 16:28
0
\$\begingroup\$

This edge condition was recently fixed, so it should work now.

\$\endgroup\$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .