0
\$\begingroup\$

I keep reporting this advert because I can't disable it and it's annoying me. Nothing appears to be being done about it. So, why does pressing the ad-choices button take you to some random yahoo site instead of the ad-choices so that I can disable it?

enter image description here

UPDATE

SE Adverts no longer are seen on my PC as of 30th March 2022. I don't know what happened other than the advert picture changed and, I clicked on the ad-choice link and, it allowed me to disable it properly. Fingers crossed it won't happen again.

\$\endgroup\$
13
  • \$\begingroup\$ You have 371k rep. How come you see ads? I believe ads are removed at 200rep. I don't see any on my side, and I have no ad blocker. Anyway, I think on the main meta there will be better answers for this: this is not site-specific. \$\endgroup\$
    – dim
    Feb 27 at 12:13
  • 1
    \$\begingroup\$ @dim I have no idea why I see ads and I didn't realize that above a certain rep you shouldn't. \$\endgroup\$
    – Andy aka
    Feb 27 at 12:31
  • \$\begingroup\$ I'm not quite sur about this, though. This page of the help center serms to contradict my thoughts: electronics.stackexchange.com/help/privileges/reduced-ads. But when I saw your screenshot, I felt like it didn't look like what I usually see, but rather something I see on sites on which I have no rep. And I checked, I don't have ads at all on EE.SE. Strange. \$\endgroup\$
    – dim
    Feb 27 at 12:37
  • \$\begingroup\$ @dim do you see the microsoft azure ad (as per the picture in my question above) on this link: electronics.stackexchange.com/questions/610170/… \$\endgroup\$
    – Andy aka
    Feb 27 at 12:38
  • \$\begingroup\$ OK the ad is there but the picture has changed - scroll down a bit - it's on the right hand side. Just checked again and it looks like the picture in the ad alternates - it still takes you to yahoo when you click ad-choices though. \$\endgroup\$
    – Andy aka
    Feb 27 at 12:39
  • \$\begingroup\$ Honestly, I see no ad at all. Here is what the page looks like on my side: i.stack.imgur.com/juESA.png \$\endgroup\$
    – dim
    Feb 27 at 15:07
  • \$\begingroup\$ I smell some covert fixing is going on. I can no longer see the ad for azure but, clearly I once did @dim \$\endgroup\$
    – Andy aka
    Feb 27 at 15:12
  • \$\begingroup\$ Amendment: I can't see ads on my iPad but I can see them on my laptop (as reported before). \$\endgroup\$
    – Andy aka
    Feb 27 at 15:24
  • \$\begingroup\$ I wasn't even aware that there are ads on SE sites :P but then I have both an ad-block browser extension and a Pi-hole filtering my LAN's DNS so ... \$\endgroup\$
    – brhans
    Feb 28 at 3:15
  • \$\begingroup\$ Did you try user profile -> edit profile -> preferences -> enable advertisements = off. \$\endgroup\$
    – Lundin
    Mar 1 at 12:48
  • \$\begingroup\$ @Lundin I have ads disabled as per this picture: i.stack.imgur.com/tjsgx.png \$\endgroup\$
    – Andy aka
    Mar 1 at 12:55
  • 2
    \$\begingroup\$ I had no idea that there were ads :-). I get a stack overflow teams ad at left - which my brain filters out. Otherwise I see none on Android phone or Windows. \$\endgroup\$
    – Russell McMahon Mod
    Mar 4 at 9:57
  • \$\begingroup\$ I'm so used to seeing ads I guess it would be strange not to see them. However, it does appear that I shouldn't be seeing ads so, how to stop them @RussellMcMahon - the original question still stands of course - why, when clicking on the advert's ad-choices button does it go to a yahoo page. \$\endgroup\$
    – Andy aka
    Mar 4 at 10:00

0

You must log in to answer this question.

Browse other questions tagged .