I have noticed that I can't edit my old schematics because the EDIT button under the schematic doesn't appear after I go into edit mode on my answer. What could be the reason?

Missing EDIT button

  • 2
    \$\begingroup\$ FYI, just verified your observation. Was able to simulate the schematics of your answer at electronics.stackexchange.com/a/672648/268467, but when I tried to edit, there was no option. Maybe the link has moved, as I edited one yesterday. \$\endgroup\$ Commented Aug 5, 2023 at 10:41
  • 1
    \$\begingroup\$ I'm going to see if we can figure out what's going on here - in the interim, can you "edit" by creating a new schematic? I'm not familiar enough with the tool to know if simulating it allows you to copy it so you can easily recreate it. :) \$\endgroup\$
    – Catija
    Commented Aug 7, 2023 at 13:15
  • \$\begingroup\$ @Catija, There is a problem only with relatively old schematics; with newly created ones there is none. \$\endgroup\$ Commented Aug 7, 2023 at 13:28
  • \$\begingroup\$ @Catija I can replicate the problem as reported. It seems likely that the older schematics are not seen by the system as having a valid Circuit Lab account. They can sometimes be edited BUT the edits cannot be saved. The system asks you to log in or to create a new account. It seems that the system has "forgotten" that these schematics were covered by the SE licence. \$\endgroup\$
    – Russell McMahon Mod
    Commented Aug 7, 2023 at 13:43
  • 1
    \$\begingroup\$ Is it possible that the issue is on the CircuitLab side? For example, maybe they only retain enough info to edit the schematic for a certain amount of time and after that, they just retain the image itself? Sorry if this sounds odd - I don't actually know how it works. \$\endgroup\$
    – Catija
    Commented Aug 7, 2023 at 13:46
  • \$\begingroup\$ @Catija, It is not odd, and that is exactly my suspicion. If so, it will create a lot of difficulties for us (at least for me because I frequently use old schematics). \$\endgroup\$ Commented Aug 7, 2023 at 13:58
  • 2
    \$\begingroup\$ Yeah, I'll see if I can find someone internally who has a contact over at CircuitLab to see if we can pin down what's going on. :) \$\endgroup\$
    – Catija
    Commented Aug 7, 2023 at 13:59
  • 1
    \$\begingroup\$ @Catija When you attempt to edit the schematic they indicate that you need to log in or to create an account. ie the problem seems to be with account status and not with the file. \$\endgroup\$
    – Russell McMahon Mod
    Commented Aug 8, 2023 at 0:40
  • 1
    \$\begingroup\$ Looks like we won't need to reach out to anyone for help on this. Y'all's work to diagnose and find a repro for this has helped us identify a bug on our end! \$\endgroup\$
    – Catija
    Commented Aug 10, 2023 at 15:07
  • \$\begingroup\$ @Catija, I have asked the same question in CircuitLab Support Forum. \$\endgroup\$ Commented Aug 10, 2023 at 15:14

3 Answers 3


The problem appears to be that in older CircuitLab schematics, the image was saved as https:..., but in newer schematics, the image is saved as http:...

Changing the text in the markup from https to http seems to fix the problem. However, I am not aware of the security issues involved, or why the change was made.

I have tested the change on this answer (rev 10)

My guess is that CircuitLab stores the editable schematics in a database, and the URL of the png image file is used as a key to recover the schematic. At some point, the names changed from https... to http...

Again, I have no idea what the security implications of the change are. Since the URL only fetches an image, I imagine there is no danger in the change, but I am not a security expert.

  • \$\begingroup\$ Thanks! This is still a solution to the problem, although it is good to understand its essence. Is it something to do with my browser settings? But you and others have the same problem... \$\endgroup\$ Commented Aug 8, 2023 at 14:15
  • \$\begingroup\$ I don't think it has to do with browser settings. I think it was a change made by CircuitLab, or possibly at EESE. \$\endgroup\$ Commented Aug 8, 2023 at 14:22
  • \$\begingroup\$ So we'll wait for an explanation from the people responsible... \$\endgroup\$ Commented Aug 8, 2023 at 14:23
  • 3
    \$\begingroup\$ This is a suuuuuper helpful realization and I had the devs check whether we explicitly require http in the code to create the edit link and we do, so hopefully making an update to check for both http and https will solve this problem without y'all having to do a bunch of editing. We'll get an update here when we've made the changes. \$\endgroup\$
    – Catija
    Commented Aug 10, 2023 at 15:05

tl;dr: The fix should be out in production now. Please let me know if you're still seeing issues with schematic-related links.

Big thanks to Math Keeps Me Busy for the HTTP vs HTTPS pointer. I'm not entirely sure how we're ending up with http for newly created schematics (I looked a bit through the image upload code, but nothing jumped out at me), but either way, when we process the post markdown, we convert http to https. It looks like at that point the post revision has one thing and the rendered HTML has another. My guess is that in past we did a mass edit of posts to rewrite existing image urls to https, but parts of the code that makes the schematic editor work didn't get the memo.


(from comments)

When you attempt to edit the schematic they indicate that you need to log in or to create an account.

I have discovered a work around. I hope it is OK to post this as an answer, even though the problem persists.

  1. Open EESE in two browser tabs.
  2. In one tab, open the edit window the question or answer of interest.
  3. With the edit window open, add a new CircuitLab editor just below the uneditable schematic
  4. In the other tab, click "simulate this circuit"
  5. When CircuitLab opens, select the entire circuit with CNTRL/A, then copy it to clipboard with CNTRL/C
  6. Go back to the first tab, and paste the clipboard into CircuitLab with CNTRL/V. (Surprise! it works.)
  7. Save the exit CircuitLab.
  8. Remove the markup for the uneditable circuit from the text in the edit window.
  9. Save and exit the edit window.

Just for a little truth in advertising. It worked on my MacBook Air running macOS High Sierra. I didn't actually use "CNTRL/X" for the various commands, but "Command/X" on my keypad. I am guessing, but could be wrong, that the clipboard works the same on Windows as it does on my Mac. However, it is conceivable that it doesn't, so would like to hear feedback.

  • \$\begingroup\$ Thanks! I tried it with this answer and it became an even bigger problem that I'm not sure how to solve now. I fixed the first schematic this way and it became editable... but to my dismay the "simulate" buttons below the other schematics disappeared. Now I'm wondering how to get it back to its previous state. I'm not sure exactly what "rollback" does and I daren't press it. Now I can neither edit nor simulate. Would you assist me? \$\endgroup\$ Commented Aug 8, 2023 at 13:51
  • \$\begingroup\$ Can you explain this "https to http"? Should I apply it to the rest schematic URLs? \$\endgroup\$ Commented Aug 8, 2023 at 14:11
  • \$\begingroup\$ I have added another answer. http is unsecured hypertext transfer protocol, https is secured hypertext transfer protocol. The secured version uses certificates for authentication. Why a change was made, I don't know. What the security implications are, I don't know. But changing the https to http fixes that schematic. :-) \$\endgroup\$ Commented Aug 8, 2023 at 14:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .