I second the "random-number" tag proposition. It will be obvious that it's about generating them.
I think that the "generator" and "function-generator" tags you mention should be removed those questions. "Generator" refers to generating electric power, and "function-generator" generates electrical signals.
Grounding and Earthing are probably used interchangeably on this site and I agree they could be merged, possibly after looking at some statistics which I don't know how to do.
I think there's a big difference between questions about ground and questions about grounding. They are not synonyms, and if they are used as such, the questions should be re-tagged ...
I had enough rep on the uart tag to suggest the synonym, now it needs up or down votes.
Edit: As PeterJ has pointed out, the voting is done at the Synonyms page for the uart tag https://electronics.stackexchange.com/tags/uart/synonyms
Alternatively, you can see all tag synonyms currently up for vote here: https://electronics.stackexchange.com/tags/synonyms
There are (currently) 35 simulator questions, and 355 simulation questions. While there could be a distinction between the two tags, in practice there isn't.
Edit: With a community vote of 3 in favor, 1 against, the tags will be merged.
I'm inclined to make the tag motor-controller and merge both esc and speedcontroller into it. I'm not sure that the distinction between BLDC and brushed DC motors is useful in the tags, but I'm open to corrections.
Tags esc, speedcontroller, andspeed-controller have been merged together. They all have synonyms to motor-controller.
While most circuits have a "ground" reference, not everything is grounded to Earth. Thus they aren't necessarily synonymous.
Common bench power supplies may have both "ground" (-) and "Earth" (green) jacks, but coupling them may be optional, since they are not the same thing.
Maybe that's not enough to keep the tags separate though...
I went ahead and merged pin->pins and fuse->fuses.
There's some room to be pedantic about the difference between pins and pinout, but I'm not sure that it's necessarily worth enforcing or cleaning. Right now, vote for this post if you agree with merging pinout -> pins. Otherwise, suggest an alternate course of action in an answer below.